Yet another racer :)

fabtax
Messages : 6
Enregistré le : 05 Juin 2016, 20:56

Yet another racer :)

Messagepar fabtax » 07 Juin 2016, 13:52

Bonjour à tous,

C'est à mon tour d'exposer mon projet de construction d'un racer :)

Voici ma liste des composants :
- 1 QAV 210 Lumenier
- 4 ESC Lumenier SimonK 20K Oneshot 125 avec BEC (que je n'utilise pas)
- 4 Moteurs Lumenier RX2204-14 2300Kv
- 4 Tripales GEMFAN 5x4,5
- 1 Camera FPV Lumenier CM-650 - 5~20v - 650TVL
- 1 Tx Lumenier TX5GPRO Mini 600*mW 5.8GHz 32CH Raceband ready
- 1 Récepteur FrSky X4R SB (3/16 voies)
- 1 Taranis X9D plus sous OpenTX 2.18
- 1 barre de led Matek Led RGB WS2812B
- 1 Régulateur Pololu 5 volts step down
- 1 FC SP Racing EVO sous cleanflight 1.13
- 1 Batterie Tattu 3S 1550mAh
- 1 Micro miniosd KV mod flashé sous MWOSD 1.6

Pour le montage pas de réels problèmes, j'ai néanmoins réajuster tous les câbles afin d'éliminer le surplus.

Voici en gros mon schéma de montage :
montage.jpg


Le RX est en SBUS+SmartPort.

A ce stade tout est fonctionnel je dirai.

Après avoir tout assemblé testé à blanc, je me suis décidé à faire un essai de vol...
Le résultat est que mon racer s'est lamentablement vautré dès de la décollage ...
Après avoir vérifié le sens de mes pales je me suis décidé à le passer avec le configurator, résultat durant mes mises à jour j'avais oubliais de décaler le GYRO ...

Je suis en attente des nouvelles hélices pour retester...

Pendant cette atente, je me suis recollé sous le configurator et je rencontre un phénomène assez étrange.
Je m'explique : quand je mets en marche mes moteurs avec le curseur master du configurator (en enlevant mes hélices bien sur), ces dernières fonctionnent toutes à la même vitesse.
Si je passe par ma télécommande en armant mes moteurs et en bougeant le throttle et le reste puis en laissant le throttle actif, mes moteurs ne sont plus tous à la même vitesse ...

Quelqu'un sait il pourquoi?

Merci pour vos lumières :)
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

Avatar de l’utilisateur
Hatem91
Messages : 1627
Enregistré le : 24 Avr 2015, 20:41
Localisation : Orsay
Contact :

Re: Yet another racer :)

Messagepar Hatem91 » 07 Juin 2016, 14:35

Cool ton racer :super:

En effet les premiers décollages sont pas toujours réussi mais on apprend ^^

Pour tes moteurs :

Vérifie que ton min trotle soit bien à 1000 et max trotle a 2000 dans cleanflight

Puis ajuste ta courbe de gaz de la radio pour que la course aille bien de 1000 a 2000 sous cleanflight dans l'onglet recepteur

Puis calibre

Tout doit être bon
lunette: Fatshark Dominator Hd V2
Quad: ZMR 250 + Thorax HK + Diatone ET160 + LS210
Radio: Graupner Mz24 + Mx16
Engins: Trex 450 - Aile Wing Wing Z84 - Aile Teksumo - Bixler 2 - F4u Corsair

MB3Drift
Messages : 118
Enregistré le : 26 Jan 2016, 15:21

Re: Yet another racer :)

Messagepar MB3Drift » 07 Juin 2016, 15:28

en bougeant les master, c est le configurateur qui pilote les moteurs 1 par 1, à une valeur précise, donc tes moteurs tournent bien tous à la même vitesse car le calcul est inexistant: le configurator dit 1060, ça tourne à 1060, point.
Quand tu armes et que tu mets le throttle, les commandes passent par la carte de vol, et donc par tes PIDs, et donc par des calculs et des approximations. Donc tu récupères des erreurs, et comme les moteurs n'ont pas de capteur de position du rotor (on est en brushless sensorless, pas sensored) et qu'ils tournent à vide (donc très librement), les erreurs augmentent.

Moi les moteurs accroissent leurs erreurs avec le temps (2 accélèrent, 2 ralentissent) si j'arme sans hélices, si je mets les hélices et que j'arme, régime constant pour les 4.

Avatar de l’utilisateur
Hatem91
Messages : 1627
Enregistré le : 24 Avr 2015, 20:41
Localisation : Orsay
Contact :

Re: Yet another racer :)

Messagepar Hatem91 » 07 Juin 2016, 16:18

en bougeant les master, c est le configurateur qui pilote les moteurs 1 par 1, à une valeur précise, donc tes moteurs tournent bien tous à la même vitesse car le calcul est inexistant: le configurator dit 1060, ça tourne à 1060, point.
Quand tu armes et que tu mets le throttle, les commandes passent par la carte de vol, et donc par tes PIDs, et donc par des calculs et des approximations. Donc tu récupères des erreurs, et comme les moteurs n'ont pas de capteur de position du rotor (on est en brushless sensorless, pas sensored) et qu'ils tournent à vide (donc très librement), les erreurs augmentent.

Moi les moteurs accroissent leurs erreurs avec le temps (2 accélèrent, 2 ralentissent) si j'arme sans hélices, si je mets les hélices et que j'arme, régime constant pour les 4.


Je ne suis pas d'accord, 1060 est une info transmise à l'esc par la carte de vol; si ce dernier a des infos avec un aux min trotle par ex 1100 alors il ne fera pas tourner le moteur.

Si le min est à 1000 dans l'esc alors à 1060 sur cleanflight, alors il s'embalera plus qu'il ne faut.

Pour les moteurs qui ralentissent ou accélèrent, c'est simple c'est la carte de vol qui veux compenser et y va de manière progressive. Il te suffit d'agir sur ta radio par ex pour régler ce phénomène en "indiquant" au quad une autre position plus proche que celle dans laquelle le quad est posé.

Ex : 2 moteurs opposés accélerent (avant droit et arrière gauche) et les 2 autres ralentissent --> la position du quad sur le Yaw est pas parfaite donc donner un minime ordre sur le yaw à la radio rééquilibrera les 4 moteurs..
lunette: Fatshark Dominator Hd V2
Quad: ZMR 250 + Thorax HK + Diatone ET160 + LS210
Radio: Graupner Mz24 + Mx16
Engins: Trex 450 - Aile Wing Wing Z84 - Aile Teksumo - Bixler 2 - F4u Corsair

fabtax
Messages : 6
Enregistré le : 05 Juin 2016, 20:56

Re: Yet another racer :)

Messagepar fabtax » 07 Juin 2016, 20:56

Salut,

Merci pour vos retours avisés.
En effet j'ai omis de prendre en compte le PID ....
Pour sa configuration je me suis inspiré de celle proposée dans le tuto de construction de fpv flight club.
Je vais recalibrer mes ESC au cas ou :)

Avatar de l’utilisateur
Hatem91
Messages : 1627
Enregistré le : 24 Avr 2015, 20:41
Localisation : Orsay
Contact :

Re: Yet another racer :)

Messagepar Hatem91 » 07 Juin 2016, 22:13

Code : Tout sélectionner

Merci pour vos retours avisés.
En effet j'ai omis de prendre en compte le PID ....
Pour sa configuration je me suis inspiré de celle proposée dans le tuto de construction de fpv flight club.
Je vais recalibrer mes ESC au cas ou :)


Veille surtotu a ce que ta courbe de gaz de la radio soit la même que celle sur cleanflight pour calibrer justement
lunette: Fatshark Dominator Hd V2
Quad: ZMR 250 + Thorax HK + Diatone ET160 + LS210
Radio: Graupner Mz24 + Mx16
Engins: Trex 450 - Aile Wing Wing Z84 - Aile Teksumo - Bixler 2 - F4u Corsair

fabtax
Messages : 6
Enregistré le : 05 Juin 2016, 20:56

Re: Yet another racer :)

Messagepar fabtax » 07 Juin 2016, 23:52

Je ne me suis pas encore pencher dessus :)
Il va falloir que je le fasse !

Merci pour l'info !


Retourner vers « Construction Perso »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité