[SITL] avec xplane

Avatar de l’utilisateur
macfly1202
Messages : 1531
Enregistré le : 12 Mai 2015, 16:16
Localisation : Guipavas

Re: [SITL] avec xplane

Messagepar macfly1202 » 11 Mai 2017, 14:03

en fait c'est pas tout a fait ca hotrod : le mode HIL utilise le pixhawk (l'apm n'est plus compatible depuis arduplane version 3.3 de memoire)
Le mode SITL ne necessite pas de brancher ton apm ou pixhawk - ca tourne en software ! c'est bcp plus recent que le mode HIL qui m'a fait gouter aux joies de l'apm au debut.
Testé ok avec xplane 9 et xplane 10. Xplane 11 cest tres boff : ca rame bcp (gros lague desagreable au pilotage)

Bon vols virtuels ! :D
lunettes: HeadPlay HD
Radio: TARANIS & Crossfire,Lora,Ezuhf,OpenLRS,FrSky
Aile: Caipi, Fx61, MiniZ, Reptile
Avions: SuperSkySurfer 2000, MiniTalon, NanoTalon, Goblin,...
Minis :Aero-Tek P'tiot, Quattrovolante Q85
Contro: APM, Pixfalcon, Guardian, Vector,
Traker: ET, ASM, zs6ubj

Iloco34
Messages : 5
Enregistré le : 14 Nov 2017, 08:21

Re: [SITL] avec xplane

Messagepar Iloco34 » 17 Nov 2017, 18:24

bonsoir à tous

j'ai suivi les conseils de ce fil mais xplane et mission planner ne se connectent pas. Les deux sont installés sur le même PC. Xplane est configuré comme image jointe.
Lorsque je lance la simulation MP elle essaie de se connecter par TCP mais n'y arrive pas.
Je suis preneur d'une solution.

Capture01.jpg


merci
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

Avatar de l’utilisateur
kristoc'h
Messages : 726
Enregistré le : 30 Sep 2015, 18:54

Re: [SITL] avec xplane

Messagepar kristoc'h » 17 Nov 2017, 20:21

salut iloco34, bienvenu.
ce serait sympa aussi de se présenter dans la rubrique idoine ;)
Lunettes: HeadPlay HD, HobbyKing Quanum v2
Radio: TARANIS X9D+
Multi: tout est hors d'usage :)
Aile: Reptile S800 SkyShadow, ZOHD NanoTalon, Parrot Disco, Reptile S1100 Harrier, SkyHunter 1800

Iloco34
Messages : 5
Enregistré le : 14 Nov 2017, 08:21

Re: [SITL] avec xplane

Messagepar Iloco34 » 17 Nov 2017, 22:08

Exact je pensais l'avoir déjà fait. J'y vais de ce pas. Mille excuses

Avatar de l’utilisateur
macfly1202
Messages : 1531
Enregistré le : 12 Mai 2015, 16:16
Localisation : Guipavas

Re: [SITL] avec xplane

Messagepar macfly1202 » 18 Nov 2017, 14:47

Salut Iloco34.
Bravo, deja tu as fait un super choix que de vouloir tester xplane et mission planner ! tu verras c'est tres chouette mais c'est comme windows, parfois capricieux.
Alors petite verification :

quel OS ? win 7 8 9 10 ?
Mission planner : version ?
Xplane : quelle version ?

Ensuite, on lance d'abord Xplane. On setup tout correctement. Ca semble OK sur ta capture. Reste la partie reseau Output. 1 rangee de case : 3,4 et 16 à 20 inclus a minima. Apres conenction cela se modifera. Ne me demande pas pourquoi c'est aussi curieux : aucune idee.
parametre ta radio en mode USB avec un mode simulateur. Pour ma part, une taranis que j'allume, je selectionne mon mode simulation windows que j'ai cree (pour tous les dongles de simu, velocidrone, FPC event etc). Ensuite branchement cable usb puis on eteins taranis qui reste allumé par alim usb.
On fait le setup dans le menu joystick

taranis_usb.PNG


Puis on lance mission planner. On va dans Simulation. Il n'y a AUCUN pix ou autre autopilot branché en USB. On choisi xplane dans menu deroulant.
simuMP.PNG


Cela doit en principe 1/ telecharger le firmware et 2/ lancer la connection pour donner :
misionplanner.PNG


Plutot que de laisser 127.0.0.1, tu peux essayer ton adresse ip local qui etait 192.168.1.28 qui etait celle la sur capture. (lance terminal menu demarrer, executer 'cmd' puis ipconfig te donne ton adresse local). Je ne connait pas ton niveau en informatqiue alors difficile d'aider plus.
Peut etre as tu un autre logiciel/service qui utilise ces port 49000/490001
Si jamais ca bloque encore, installe teamviewer et on pourra se connecter pour essayer de faire marcher tout ca. N'hesite pas !

ps: saches que tu peux egalement tester avec qgrouncontrol et la version firmware PX4 1.5.5 (PX4 n'etant PAS ardupilot) cf https://github.com/PX4/Firmware/issues/5651
ps2: je viens de verifier pour mission planner (MP) build1.3.50.1 et ca fonctionne

Excellent WE !
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
lunettes: HeadPlay HD
Radio: TARANIS & Crossfire,Lora,Ezuhf,OpenLRS,FrSky
Aile: Caipi, Fx61, MiniZ, Reptile
Avions: SuperSkySurfer 2000, MiniTalon, NanoTalon, Goblin,...
Minis :Aero-Tek P'tiot, Quattrovolante Q85
Contro: APM, Pixfalcon, Guardian, Vector,
Traker: ET, ASM, zs6ubj

Iloco34
Messages : 5
Enregistré le : 14 Nov 2017, 08:21

Re: [SITL] avec xplane

Messagepar Iloco34 » 03 Jan 2018, 11:04

bonjour et bonne année à tous

je m'excuse auprès de toi macfly1202 car j'ai tardé à te répondre. Je n'avais pas mis mon sujet en surveillance. Je vais tester ton tuto de suite.
Bon j'ai réussi à connecter. Maintenant il ne me reste plus qu'à faire un plan de vol et de le faire fonctionner en simulation auto.
C'est surtout cette fonction qui m'intéresse. Je n'arrive pas a armer j'ai "bad AHRS" et "bad Gyro Healt" et quand j'essaye d'armer pour faire une mission, j'ai le message "error command rejected"
Merci beaucoup

Pour info
windows 10
xplane 10
MP 1.3.52

Avatar de l’utilisateur
macfly1202
Messages : 1531
Enregistré le : 12 Mai 2015, 16:16
Localisation : Guipavas

Re: [SITL] avec xplane

Messagepar macfly1202 » 09 Jan 2018, 19:29

salut ! desactive les verrous a l'armement : arm_require par ex et arm_rudder http://ardupilot.org/plane/docs/arming-your-plane.html

desactive les pour test mais attention ne JAMAIS les desactiver sur un avion/quad au risque de perdre sa machine ou se faire couper la main.
En mode SITL, c'est tjrs capricieux et j'en sais qlq chose.

je vais checker plus svt mes messages !
lunettes: HeadPlay HD
Radio: TARANIS & Crossfire,Lora,Ezuhf,OpenLRS,FrSky
Aile: Caipi, Fx61, MiniZ, Reptile
Avions: SuperSkySurfer 2000, MiniTalon, NanoTalon, Goblin,...
Minis :Aero-Tek P'tiot, Quattrovolante Q85
Contro: APM, Pixfalcon, Guardian, Vector,
Traker: ET, ASM, zs6ubj

Iloco34
Messages : 5
Enregistré le : 14 Nov 2017, 08:21

Re: [SITL] avec xplane

Messagepar Iloco34 » 09 Jan 2018, 19:52

Ok merci je vais essayer çà demain.

Bon j'ai essayé plusieurs fois. La connexion est bonne. J'ai enlevé les contrôles d'armement. je lance la mission. Et là l'avion fait n'importe quoi. Il va dans n'importe quelle direction. Il monte, il descend enfin il vit tout seul mais ne fait pas du tout la mission. Comment faire pour réaliser une mission auto dans ce mode de simulation?

merci


Retourner vers « Simulateurs »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invité